CVE-2017-14158CVE-2017-14158

Affected configuration(s):

cpe:/a:scrapy:scrapy:1.4

Date published: 2017-09-05T13:29:00.230-04:00

Date last modified: 2017-09-07T15:52:08.707-04:00

CVSS Score: 7.8

Principal attack vector: NETWORK

Complexity:  LOW

Reference URL: http://blog.csdn.net/wangtua/article/details/75228728

Summary: Scrapy 1.4 allows remote attackers to cause a denial of service (memory consumption) via large files because arbitrarily many files are read into memory, which is especially problematic if the files are then individually written in a separate thread to a slow storage resource, as demonstrated by interaction between dataReceived (in core/downloader/handlers/http11.py) and S3FilesStore.

CategoriesUncategorised

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.