CVE-2017-14033CVE-2017-14033

Affected configuration(s):

cpe:/a:ruby-lang:ruby:2.2.0
cpe:/a:ruby-lang:ruby:2.2.0:preview1
cpe:/a:ruby-lang:ruby:2.2.0:preview2
cpe:/a:ruby-lang:ruby:2.2.0:rc1
cpe:/a:ruby-lang:ruby:2.2.1
cpe:/a:ruby-lang:ruby:2.2.2
cpe:/a:ruby-lang:ruby:2.2.3
cpe:/a:ruby-lang:ruby:2.2.4
cpe:/a:ruby-lang:ruby:2.2.5
cpe:/a:ruby-lang:ruby:2.2.6
cpe:/a:ruby-lang:ruby:2.2.7
cpe:/a:ruby-lang:ruby:2.3.0
cpe:/a:ruby-lang:ruby:2.3.0:preview1
cpe:/a:ruby-lang:ruby:2.3.0:preview2
cpe:/a:ruby-lang:ruby:2.3.1
cpe:/a:ruby-lang:ruby:2.3.2
cpe:/a:ruby-lang:ruby:2.3.3
cpe:/a:ruby-lang:ruby:2.3.4
cpe:/a:ruby-lang:ruby:2.4.0
cpe:/a:ruby-lang:ruby:2.4.0:preview1
cpe:/a:ruby-lang:ruby:2.4.0:preview2
cpe:/a:ruby-lang:ruby:2.4.0:preview3
cpe:/a:ruby-lang:ruby:2.4.0:rc1
cpe:/a:ruby-lang:ruby:2.4.1

Date published: 2017-09-19T13:29:00.327-04:00

Date last modified: 2017-11-12T21:29:02.650-05:00

CVSS Score: 5.0

Principal attack vector: NETWORK

Complexity:  LOW

Reference URL: http://www.securityfocus.com/bid/100868

Summary: The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string.

CategoriesUncategorised

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.