CVE-2017-11499CVE-2017-11499

Affected configuration(s):

cpe:/a:nodejs:node.js:4.0.0
cpe:/a:nodejs:node.js:4.1.0
cpe:/a:nodejs:node.js:4.1.1
cpe:/a:nodejs:node.js:4.1.2
cpe:/a:nodejs:node.js:4.2.0
cpe:/a:nodejs:node.js:4.2.1
cpe:/a:nodejs:node.js:4.2.2
cpe:/a:nodejs:node.js:4.2.3
cpe:/a:nodejs:node.js:4.2.4
cpe:/a:nodejs:node.js:4.2.5
cpe:/a:nodejs:node.js:4.2.6
cpe:/a:nodejs:node.js:4.3.0
cpe:/a:nodejs:node.js:4.3.1
cpe:/a:nodejs:node.js:4.3.2
cpe:/a:nodejs:node.js:4.4.0
cpe:/a:nodejs:node.js:4.4.1
cpe:/a:nodejs:node.js:4.4.2
cpe:/a:nodejs:node.js:4.4.3
cpe:/a:nodejs:node.js:4.4.4
cpe:/a:nodejs:node.js:4.4.5
cpe:/a:nodejs:node.js:4.4.6
cpe:/a:nodejs:node.js:4.4.7
cpe:/a:nodejs:node.js:4.5.0
cpe:/a:nodejs:node.js:4.6.0
cpe:/a:nodejs:node.js:4.6.1
cpe:/a:nodejs:node.js:4.6.2
cpe:/a:nodejs:node.js:4.7.0
cpe:/a:nodejs:node.js:4.7.1
cpe:/a:nodejs:node.js:4.7.2
cpe:/a:nodejs:node.js:4.7.3
cpe:/a:nodejs:node.js:4.8.0
cpe:/a:nodejs:node.js:4.8.1
cpe:/a:nodejs:node.js:4.8.2
cpe:/a:nodejs:node.js:4.8.3
cpe:/a:nodejs:node.js:5.0.0
cpe:/a:nodejs:node.js:5.1.0
cpe:/a:nodejs:node.js:5.1.1
cpe:/a:nodejs:node.js:5.2.0
cpe:/a:nodejs:node.js:5.3.0
cpe:/a:nodejs:node.js:5.4.0
cpe:/a:nodejs:node.js:5.4.1
cpe:/a:nodejs:node.js:5.5.0
cpe:/a:nodejs:node.js:5.6.0
cpe:/a:nodejs:node.js:5.7.0
cpe:/a:nodejs:node.js:5.7.1
cpe:/a:nodejs:node.js:5.8.0
cpe:/a:nodejs:node.js:5.9.0
cpe:/a:nodejs:node.js:5.9.1
cpe:/a:nodejs:node.js:5.10.0
cpe:/a:nodejs:node.js:5.10.1
cpe:/a:nodejs:node.js:5.11.0
cpe:/a:nodejs:node.js:5.11.1
cpe:/a:nodejs:node.js:5.12.0
cpe:/a:nodejs:node.js:6.0.0
cpe:/a:nodejs:node.js:6.1.0
cpe:/a:nodejs:node.js:6.2.0
cpe:/a:nodejs:node.js:6.2.1
cpe:/a:nodejs:node.js:6.2.2
cpe:/a:nodejs:node.js:6.3.0
cpe:/a:nodejs:node.js:6.3.1
cpe:/a:nodejs:node.js:6.4.0
cpe:/a:nodejs:node.js:6.5.0
cpe:/a:nodejs:node.js:6.6.0
cpe:/a:nodejs:node.js:6.7.0
cpe:/a:nodejs:node.js:6.8.0
cpe:/a:nodejs:node.js:6.8.1
cpe:/a:nodejs:node.js:6.9.0
cpe:/a:nodejs:node.js:6.9.1
cpe:/a:nodejs:node.js:6.9.2
cpe:/a:nodejs:node.js:6.9.3
cpe:/a:nodejs:node.js:6.9.4
cpe:/a:nodejs:node.js:6.9.5
cpe:/a:nodejs:node.js:6.10.0
cpe:/a:nodejs:node.js:6.10.1
cpe:/a:nodejs:node.js:6.10.2
cpe:/a:nodejs:node.js:6.10.3
cpe:/a:nodejs:node.js:6.11.0
cpe:/a:nodejs:node.js:6.11.1
cpe:/a:nodejs:node.js:7.0.0
cpe:/a:nodejs:node.js:7.1.0
cpe:/a:nodejs:node.js:7.2.0
cpe:/a:nodejs:node.js:7.2.1
cpe:/a:nodejs:node.js:7.3.0
cpe:/a:nodejs:node.js:7.4.0
cpe:/a:nodejs:node.js:7.5.0
cpe:/a:nodejs:node.js:7.6.0
cpe:/a:nodejs:node.js:7.7.0
cpe:/a:nodejs:node.js:7.7.1
cpe:/a:nodejs:node.js:7.7.2
cpe:/a:nodejs:node.js:7.7.3
cpe:/a:nodejs:node.js:7.7.4
cpe:/a:nodejs:node.js:7.8.0
cpe:/a:nodejs:node.js:7.9.0
cpe:/a:nodejs:node.js:7.10.0
cpe:/a:nodejs:node.js:7.10.1
cpe:/a:nodejs:node.js:8.0.0
cpe:/a:nodejs:node.js:8.1.0
cpe:/a:nodejs:node.js:8.1.1
cpe:/a:nodejs:node.js:8.1.2
cpe:/a:nodejs:node.js:8.1.3

Date published: 2017-07-25T09:29:00.177-04:00

Date last modified: 2017-12-06T21:29:12.883-05:00

CVSS Score: 5.0

Principal attack vector: NETWORK

Complexity:  LOW

Reference URL: http://www.securityfocus.com/bid/99959

Summary: Node.js v4.0 through v4.8.3, all versions of v5.x, v6.0 through v6.11.0, v7.0 through v7.10.0, and v8.0 through v8.1.3 was susceptible to hash flooding remote DoS attacks as the HashTable seed was constant across a given released version of Node.js. This was a result of building with V8 snapshots enabled by default which caused the initially randomized seed to be overwritten on startup.

CategoriesUncategorised

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.