CVE-2014-8998CVE-2014-8998

Affected configuration(s):

cpe:/a:x7chat:x7_chat:2.0.0
cpe:/a:x7chat:x7_chat:2.0.0:a1
cpe:/a:x7chat:x7_chat:2.0.0:a2
cpe:/a:x7chat:x7_chat:2.0.0:a3
cpe:/a:x7chat:x7_chat:2.0.0:b1
cpe:/a:x7chat:x7_chat:2.0.0:b2
cpe:/a:x7chat:x7_chat:2.0.1:a1
cpe:/a:x7chat:x7_chat:2.0.2
cpe:/a:x7chat:x7_chat:2.0.3
cpe:/a:x7chat:x7_chat:2.0.4
cpe:/a:x7chat:x7_chat:2.0.4.1
cpe:/a:x7chat:x7_chat:2.0.4.3
cpe:/a:x7chat:x7_chat:2.0.4.4
cpe:/a:x7chat:x7_chat:2.0.5
cpe:/a:x7chat:x7_chat:2.0.5.1

Date published: 2014-11-20T08:55:07.907-05:00

Date last modified: 2017-09-07T21:29:31.403-04:00

CVSS Score: 6.5

Principal attack vector: NETWORK

Complexity:  LOW

Reference URL: http://packetstormsecurity.com/files/128964/X7-Chat-2.0.5-lib-message.php-preg_replace-PHP-Code-Execution.html

Summary: lib/message.php in X7 Chat 2.0.0 through 2.0.5.1 allows remote authenticated users to execute arbitrary PHP code via a crafted HTTP header to index.php, which is processed by the preg_replace function with the eval switch.

CategoriesUncategorised

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.