CVE-2014-8147CVE-2014-8147

Affected configuration(s):

cpe:/a:icu_project:international_components_for_unicode:52.0
cpe:/a:icu_project:international_components_for_unicode:53.0
cpe:/a:icu_project:international_components_for_unicode:54.0
cpe:/o:apple:mac_os_x:10.10.4
cpe:/o:apple:watchos:1.0.1

Date published: 2015-05-25T18:59:01.927-04:00

Date last modified: 2016-12-21T21:59:19.267-05:00

CVSS Score: 7.5

Principal attack vector: NETWORK

Complexity:  LOW

Reference URL: http://bugs.icu-project.org/trac/changeset/37080

Summary: The resolveImplicitLevels function in common/ubidi.c in the Unicode Bidirectional Algorithm implementation in ICU4C in International Components for Unicode (ICU) before 55.1 uses an integer data type that is inconsistent with a header file, which allows remote attackers to cause a denial of service (incorrect malloc followed by invalid free) or possibly execute arbitrary code via crafted text.

CategoriesUncategorised

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.