CVE-2014-8127CVE-2014-8127

Affected configuration(s):

cpe:/a:libtiff:libtiff:4.0.3
cpe:/o:opensuse_project:opensuse:13.1
cpe:/o:opensuse_project:opensuse:13.2

Date published: 2017-06-26T11:29:00.237-04:00

Date last modified: 2017-11-03T21:29:01.350-04:00

CVSS Score: 4.3

Principal attack vector: NETWORK

Complexity:  MEDIUM

Reference URL: http://bugzilla.maptools.org/show_bug.cgi?id=2484

Summary: LibTIFF 4.0.3 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a crafted TIFF image to the (1) checkInkNamesString function in tif_dir.c in the thumbnail tool, (2) compresscontig function in tiff2bw.c in the tiff2bw tool, (3) putcontig8bitCIELab function in tif_getimage.c in the tiff2rgba tool, LZWPreDecode function in tif_lzw.c in the (4) tiff2ps or (5) tiffdither tool, (6) NeXTDecode function in tif_next.c in the tiffmedian tool, or (7) TIFFWriteDirectoryTagLongLong8Array function in tif_dirwrite.c in the tiffset tool.

CategoriesUncategorised

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.