CVE-2014-3623CVE-2014-3623

Affected configuration(s):

cpe:/a:apache:cxf:2.7.0
cpe:/a:apache:cxf:2.7.1
cpe:/a:apache:cxf:2.7.10
cpe:/a:apache:cxf:2.7.11
cpe:/a:apache:cxf:2.7.12
cpe:/a:apache:cxf:3.0.0
cpe:/a:apache:cxf:3.0.1
cpe:/a:apache:wss4j:1.6.10
cpe:/a:apache:wss4j:1.6.11
cpe:/a:apache:wss4j:1.6.12
cpe:/a:apache:wss4j:1.6.13
cpe:/a:apache:wss4j:1.6.14
cpe:/a:apache:wss4j:1.6.15
cpe:/a:apache:wss4j:1.6.16
cpe:/a:apache:wss4j:2.0.0
cpe:/a:apache:wss4j:2.0.0-rc1
cpe:/a:apache:wss4j:2.0.1

Date published: 2014-10-30T10:55:07.833-04:00

Date last modified: 2017-08-28T21:34:48.717-04:00

CVSS Score: 5.0

Principal attack vector: NETWORK

Complexity:  LOW

Reference URL: http://rhn.redhat.com/errata/RHSA-2015-0236.html

Summary: Apache WSS4J before 1.6.17 and 2.x before 2.0.2, as used in Apache CXF 2.7.x before 2.7.13 and 3.0.x before 3.0.2, when using TransportBinding, does not properly enforce the SAML SubjectConfirmation method security semantics, which allows remote attackers to conduct spoofing attacks via unspecified vectors.

CategoriesUncategorised

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.