CVE-2014-1916CVE-2014-1916

Affected configuration(s):

cpe:/a:light_speed_gaming:mumble:1.1::~~~iphone_os~~
cpe:/a:light_speed_gaming:mumble:1.1:rc1:~~~iphone_os~~
cpe:/a:light_speed_gaming:mumble:1.1.1::~~~iphone_os~~
cpe:/a:light_speed_gaming:mumble:1.2::~~~iphone_os~~
cpe:/a:light_speed_gaming:mumble:1.2.1::~~~iphone_os~~
cpe:/a:light_speed_gaming:mumble:1.2.2::~~~iphone_os~~
cpe:/a:light_speed_gaming:mumblekit:-

Date published: 2014-02-07T19:55:06.237-05:00

Date last modified: 2014-02-10T12:26:33.363-05:00

CVSS Score: 5.0

Principal attack vector: NETWORK

Complexity:  LOW

Reference URL: http://mumble.info/security/Mumble-SA-2014-003.txt

Summary: The (1) opus_packet_get_nb_frames and (2) opus_packet_get_samples_per_frame functions in the client in MumbleKit before commit fd190328a9b24d37382b269a5674b0c0c7a7e36d and Mumble for iOS 1.1 through 1.2.2 do not properly check the return value of the copyDataBlock method, which allow remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted length prefix value in an Opus voice packet.

CategoriesUncategorised

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.