CVE-2014-0240CVE-2014-0240

Affected configuration(s):

cpe:/a:modwsgi:mod_wsgi:1.0
cpe:/a:modwsgi:mod_wsgi:1.1
cpe:/a:modwsgi:mod_wsgi:1.2
cpe:/a:modwsgi:mod_wsgi:1.3
cpe:/a:modwsgi:mod_wsgi:1.4
cpe:/a:modwsgi:mod_wsgi:1.5
cpe:/a:modwsgi:mod_wsgi:1.6
cpe:/a:modwsgi:mod_wsgi:2.0
cpe:/a:modwsgi:mod_wsgi:2.1
cpe:/a:modwsgi:mod_wsgi:2.2
cpe:/a:modwsgi:mod_wsgi:2.3
cpe:/a:modwsgi:mod_wsgi:2.4
cpe:/a:modwsgi:mod_wsgi:2.5
cpe:/a:modwsgi:mod_wsgi:2.6
cpe:/a:modwsgi:mod_wsgi:2.7
cpe:/a:modwsgi:mod_wsgi:2.8
cpe:/a:modwsgi:mod_wsgi:3.0
cpe:/a:modwsgi:mod_wsgi:3.1
cpe:/a:modwsgi:mod_wsgi:3.2
cpe:/a:modwsgi:mod_wsgi:3.3
cpe:/a:modwsgi:mod_wsgi:3.4

Date published: 2014-05-27T10:55:12.197-04:00

Date last modified: 2017-01-06T21:59:24.857-05:00

CVSS Score: 6.2

Principal attack vector: LOCAL

Complexity:  HIGH

Reference URL: http://blog.dscpl.com.au/2014/05/security-release-for-modwsgi-version-35.html

Summary: The mod_wsgi module before 3.5 for Apache, when daemon mode is enabled, does not properly handle error codes returned by setuid when run on certain Linux kernels, which allows local users to gain privileges via vectors related to the number of running processes.

CategoriesUncategorised

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.