CVE-2014-0238CVE-2014-0238

Affected configuration(s):

cpe:/a:php:php:5.0.0
cpe:/a:php:php:5.0.0:beta1
cpe:/a:php:php:5.0.0:beta2
cpe:/a:php:php:5.0.0:beta3
cpe:/a:php:php:5.0.0:beta4
cpe:/a:php:php:5.0.0:rc1
cpe:/a:php:php:5.0.0:rc2
cpe:/a:php:php:5.0.0:rc3
cpe:/a:php:php:5.0.1
cpe:/a:php:php:5.0.2
cpe:/a:php:php:5.0.3
cpe:/a:php:php:5.0.4
cpe:/a:php:php:5.0.5
cpe:/a:php:php:5.1.0
cpe:/a:php:php:5.1.1
cpe:/a:php:php:5.1.2
cpe:/a:php:php:5.1.3
cpe:/a:php:php:5.1.4
cpe:/a:php:php:5.1.5
cpe:/a:php:php:5.1.6
cpe:/a:php:php:5.2.0
cpe:/a:php:php:5.2.1
cpe:/a:php:php:5.2.2
cpe:/a:php:php:5.2.3
cpe:/a:php:php:5.2.4
cpe:/a:php:php:5.2.5
cpe:/a:php:php:5.2.6
cpe:/a:php:php:5.2.7
cpe:/a:php:php:5.2.8
cpe:/a:php:php:5.2.9
cpe:/a:php:php:5.2.10
cpe:/a:php:php:5.2.11
cpe:/a:php:php:5.2.12
cpe:/a:php:php:5.2.13
cpe:/a:php:php:5.2.14
cpe:/a:php:php:5.2.15
cpe:/a:php:php:5.2.16
cpe:/a:php:php:5.2.17
cpe:/a:php:php:5.3.0
cpe:/a:php:php:5.3.1
cpe:/a:php:php:5.3.2
cpe:/a:php:php:5.3.3
cpe:/a:php:php:5.3.4
cpe:/a:php:php:5.3.5
cpe:/a:php:php:5.3.6
cpe:/a:php:php:5.3.7
cpe:/a:php:php:5.3.8
cpe:/a:php:php:5.3.9
cpe:/a:php:php:5.3.10
cpe:/a:php:php:5.3.11
cpe:/a:php:php:5.3.12
cpe:/a:php:php:5.3.13
cpe:/a:php:php:5.3.14
cpe:/a:php:php:5.3.15
cpe:/a:php:php:5.3.16
cpe:/a:php:php:5.3.17
cpe:/a:php:php:5.3.18
cpe:/a:php:php:5.3.19
cpe:/a:php:php:5.3.20
cpe:/a:php:php:5.3.21
cpe:/a:php:php:5.3.22
cpe:/a:php:php:5.3.23
cpe:/a:php:php:5.3.24
cpe:/a:php:php:5.3.25
cpe:/a:php:php:5.3.26
cpe:/a:php:php:5.3.27
cpe:/a:php:php:5.3.28
cpe:/a:php:php:5.4.0
cpe:/a:php:php:5.4.1
cpe:/a:php:php:5.4.2
cpe:/a:php:php:5.4.3
cpe:/a:php:php:5.4.4
cpe:/a:php:php:5.4.5
cpe:/a:php:php:5.4.6
cpe:/a:php:php:5.4.7
cpe:/a:php:php:5.4.8
cpe:/a:php:php:5.4.9
cpe:/a:php:php:5.4.10
cpe:/a:php:php:5.4.11
cpe:/a:php:php:5.4.12
cpe:/a:php:php:5.4.12:rc1
cpe:/a:php:php:5.4.12:rc2
cpe:/a:php:php:5.4.13
cpe:/a:php:php:5.4.13:rc1
cpe:/a:php:php:5.4.14
cpe:/a:php:php:5.4.14:rc1
cpe:/a:php:php:5.4.15:rc1
cpe:/a:php:php:5.4.16:rc1
cpe:/a:php:php:5.4.17
cpe:/a:php:php:5.4.18
cpe:/a:php:php:5.4.19
cpe:/a:php:php:5.4.20
cpe:/a:php:php:5.4.21
cpe:/a:php:php:5.4.22
cpe:/a:php:php:5.4.23
cpe:/a:php:php:5.4.24
cpe:/a:php:php:5.4.25
cpe:/a:php:php:5.4.26
cpe:/a:php:php:5.5.0:alpha1
cpe:/a:php:php:5.5.0:alpha2
cpe:/a:php:php:5.5.0:alpha3
cpe:/a:php:php:5.5.0:alpha4
cpe:/a:php:php:5.5.0:alpha5
cpe:/a:php:php:5.5.0:alpha6
cpe:/a:php:php:5.5.0:beta1
cpe:/a:php:php:5.5.0:beta2
cpe:/a:php:php:5.5.0:beta3
cpe:/a:php:php:5.5.0:beta4
cpe:/a:php:php:5.5.0:rc1
cpe:/a:php:php:5.5.0:rc2
cpe:/a:php:php:5.5.1
cpe:/a:php:php:5.5.2
cpe:/a:php:php:5.5.3
cpe:/a:php:php:5.5.4
cpe:/a:php:php:5.5.5
cpe:/a:php:php:5.5.6
cpe:/a:php:php:5.5.7
cpe:/a:php:php:5.5.8
cpe:/a:php:php:5.5.9
cpe:/a:php:php:5.5.10
cpe:/a:php:php:5.5.11
cpe:/a:php:php:5.5.12

Date published: 2014-06-01T00:29:34.783-04:00

Date last modified: 2017-01-06T21:59:24.717-05:00

CVSS Score: 5.0

Principal attack vector: NETWORK

Complexity:  LOW

Reference URL: http://lists.apple.com/archives/security-announce/2015/Apr/msg00001.html

Summary: The cdf_read_property_info function in cdf.c in the Fileinfo component in PHP before 5.4.29 and 5.5.x before 5.5.13 allows remote attackers to cause a denial of service (infinite loop or out-of-bounds memory access) via a vector that (1) has zero length or (2) is too long.

CategoriesUncategorised

Leave a Reply

Your email address will not be published. Required fields are marked *