CVE-2014-0097CVE-2014-0097

Affected configuration(s):

cpe:/a:pivotal_software:spring_security:3.1.0
cpe:/a:pivotal_software:spring_security:3.1.1
cpe:/a:pivotal_software:spring_security:3.1.2
cpe:/a:pivotal_software:spring_security:3.1.3
cpe:/a:pivotal_software:spring_security:3.1.4
cpe:/a:pivotal_software:spring_security:3.1.5
cpe:/a:pivotal_software:spring_security:3.2.0
cpe:/a:pivotal_software:spring_security:3.2.1

Date published: 2017-05-25T13:29:00.160-04:00

Date last modified: 2017-06-07T10:23:01.297-04:00

CVSS Score: 7.5

Principal attack vector: NETWORK

Complexity:  LOW

Reference URL: https://pivotal.io/security/cve-2014-0097

Summary: The ActiveDirectoryLdapAuthenticator in Spring Security 3.2.0 to 3.2.1 and 3.1.0 to 3.1.5 does not check the password length. If the directory allows anonymous binds then it may incorrectly authenticate a user who supplies an empty password.

CategoriesUncategorised

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.